<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns# video: http://ogp.me/ns/video# ya: http://webmaster.yandex.ru/vocabularies/"><head><meta name="viewport" content="width=device-width, initial-scale=1"><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="https://www.olisa.tv/xmlrpc.php"><meta name="format-detection" content="telephone=no"><meta http-equiv="X-UA-Compatible" content="IE=edge"><title>All the Tweets Praising Pete Edochie After a Troll Claimed He&#039;s a &#039;Bad Actor&#039; - Olisa.tv</title><link rel="canonical" href="https://www.olisa.tv/all-the-tweets-praising-pete-edochie-after-trolls-claimed-hes-a-bad-actor/"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="All the Tweets Praising Pete Edochie After a Troll Claimed He&#039;s a &#039;Bad Actor&#039; - Olisa.tv"><meta property="og:description" content="Nigerians are currently rallying behind Pete Edochie, with many sharing clips of his old exceptional performances, and this all started after a Twitter troll claimed he isn&#8217;t a good actor. See the tweet that started all the drama: Pete Edochie is a really bad actor. He&#039;s been playing the same role his entire life. Acting &hellip;"><meta property="og:url" content="https://www.olisa.tv/all-the-tweets-praising-pete-edochie-after-trolls-claimed-hes-a-bad-actor/"><meta property="og:site_name" content="Olisa.tv"><meta property="article:publisher" content="https://web.facebook.com/olisa.tv/"><meta property="article:tag" content="pete edochie"><meta property="article:section" content="Celebrity"><meta property="article:published_time" content="2019-11-06T11:21:17+00:00"><meta property="article:modified_time" content="2019-11-06T11:23:44+00:00"><meta property="og:updated_time" content="2019-11-06T11:23:44+00:00"><meta property="og:image" content="https://www.olisa.tv/wp-content/uploads/2019/11/edochie.jpg"><meta property="og:image:secure_url" content="https://www.olisa.tv/wp-content/uploads/2019/11/edochie.jpg"><meta property="og:image:width" content="564"><meta property="og:image:height" content="495"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:description" content="Nigerians are currently rallying behind Pete Edochie, with many sharing clips of his old exceptional performances, and this all started after a Twitter troll claimed he isn&#8217;t a good actor. See the tweet that started all the drama: Pete Edochie is a really bad actor. He&#039;s been playing the same role his entire life. Acting [&hellip;]"><meta name="twitter:title" content="All the Tweets Praising Pete Edochie After a Troll Claimed He&#039;s a &#039;Bad Actor&#039; - Olisa.tv"><meta name="twitter:site" content="@olisatv"><meta name="twitter:image" content="https://www.olisa.tv/wp-content/uploads/2019/11/edochie.jpg"><meta name="twitter:creator" content="@olisatv"> <script type="application/ld+json">{"@context":"https://schema.org","@type":"Organization","url":"https://www.olisa.tv/","sameAs":["https://web.facebook.com/olisa.tv/","https://www.instagram.com/theolisatv/","https://www.youtube.com/user/OligarkiTV","https://twitter.com/olisatv"],"@id":"https://www.olisa.tv/#organization","name":"Olisa.tv","logo":"https://www.olisa.tv/wp-content/uploads/2018/01/NEW-Olisa.tv-logo-1-e1516637403880.png"}</script> <link rel="dns-prefetch" href="//s0.wp.com"><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="alternate" type="application/rss+xml" title="Olisa.tv &raquo; Feed" href="https://www.olisa.tv/feed/"><link rel="alternate" type="application/rss+xml" title="Olisa.tv &raquo; Comments Feed" href="https://www.olisa.tv/comments/feed/"><link rel="alternate" type="application/rss+xml" title="Olisa.tv &raquo; All the Tweets Praising Pete Edochie After a Troll Claimed He&#8217;s a &#8216;Bad Actor&#8217; Comments Feed" href="https://www.olisa.tv/all-the-tweets-praising-pete-edochie-after-trolls-claimed-hes-a-bad-actor/feed/"><link rel="stylesheet" id="wp-block-library-css" href="/wp-includes/css/dist/block-library/style.min.css" type="text/css" media="all"><link rel="stylesheet" id="pt-magazine-fonts-css" href="//fonts.googleapis.com/css?family=Domine%3A400%2C700%7CMontserrat%3A300%2C400%2C500%2C600%2C700&#038;subset=latin%2Clatin-ext" type="text/css" media="all"><link rel="stylesheet" id="jquery-meanmenu-css" href="/wp-content/themes/pt-magazine-plus/assets/third-party/meanmenu/jquery-meanmenu.min.css" type="text/css" media="all"><link rel="stylesheet" id="font-awesome-css" href="/wp-content/themes/pt-magazine-plus/assets/third-party/font-awesome/css/font-awesome.min.css" type="text/css" media="all"><link rel="stylesheet" id="jquery-slick-css" href="/wp-content/themes/pt-magazine-plus/assets/third-party/slick/jquery-slick.min.css" type="text/css" media="all"><link rel="stylesheet" id="pt-magazine-style-css" href="/wp-content/themes/pt-magazine-plus/pt-magazine-style.min.css" type="text/css" media="all"><link rel="stylesheet" id="social-logos-css" href="/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css" type="text/css" media="all"><link rel="stylesheet" id="jetpack_css-css" href="/wp-content/plugins/jetpack/css/jetpack_css.min.css" type="text/css" media="all"> <script src="/s/f.php?7fb66c.js"></script> <script type="text/javascript">var gadwpUAEventsData = {"options":{"event_tracking":"1","event_downloads":"zip|mp3*|mpe*g|pdf|docx*|pptx*|xlsx*|rar*","event_bouncerate":0,"aff_tracking":1,"event_affiliates":"\/out\/","hash_tracking":"1","root_domain":"olisa.tv","event_timeout":100,"event_precision":1,"event_formsubmit":1,"ga_pagescrolldepth_tracking":1,"ga_with_gtag":0}};</script> <script src="/s/f.php?dce0e5.js"></script> <link rel="https://api.w.org/" href="https://www.olisa.tv/wp-json/"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.olisa.tv/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.olisa.tv/wp-includes/wlwmanifest.xml"><meta name="generator" content="WordPress 5.2.4"><link rel="shortlink" href="https://wp.me/p4mB7Z-g1m"><link rel="alternate" type="application/json+oembed" href="https://www.olisa.tv/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.olisa.tv%2Fall-the-tweets-praising-pete-edochie-after-trolls-claimed-hes-a-bad-actor%2F"><link rel="alternate" type="text/xml+oembed" href="https://www.olisa.tv/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.olisa.tv%2Fall-the-tweets-praising-pete-edochie-after-trolls-claimed-hes-a-bad-actor%2F&#038;format=xml"><link rel="dns-prefetch" href="//v0.wordpress.com"><style type="text/css">img#wpstats{display:none}</style><link rel="pingback" href="https://www.olisa.tv/xmlrpc.php"><style type="text/css">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</style><link rel="icon" href="https://www.olisa.tv/wp-content/uploads/2018/01/new-Olisa.tv-logo-001-150x150.jpg" sizes="32x32"><link rel="icon" href="https://www.olisa.tv/wp-content/uploads/2018/01/new-Olisa.tv-logo-001.jpg" sizes="192x192"><link rel="apple-touch-icon-precomposed" href="https://www.olisa.tv/wp-content/uploads/2018/01/new-Olisa.tv-logo-001.jpg"><meta name="msapplication-TileImage" content="https://www.olisa.tv/wp-content/uploads/2018/01/new-Olisa.tv-logo-001.jpg"> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-59013755-1', 'auto', {'useAmpClientId': true});
  ga('require', 'displayfeatures');
  ga('require', 'linkid');
  ga('set', 'forceSSL', true);
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');</script> </head><body class="post-template-default single single-post postid-61588 single-format-standard wp-custom-logo group-blog global-layout-right-sidebar blog-layout-grid"><div id="page" class="site"><header id="masthead" class="site-header" role="banner"><div class="top-header"><div class="container"><div class="top-header-content"><div class="top-info-left left"><div class="recent-stories-holder"> <span>Trending :</span><ul id="recent-news"><li> <a href="/paul-okoye-narrates-how-he-saved-slavia-pragues-peter-olayinka-from-police-harassment/">Paul Okoye narrates how he saved Slavia Prague’s Peter Olayinka from Police Harassment</a></li><li> <a href="/new-masquerade-star-ovularia-is-reportedly-dead/">‘New Masquerade’ Star, ‘Ovularia’ is Reportedly Dead</a></li><li> <a href="/watch-sarkodies-single-party-n-bullsht-featuring-idris-elba-donaeo/">Watch Sarkodie&#8217;s Single, &#8220;Party N Bullsh*t,&#8221; Featuring Idris Elba &#038; Donae&#8217;O</a></li><li> <a href="/lungisa-xhamela-and-ami-faku-join-i-write-what-i-dream-tour/">Lungisa Xhamela and Ami Faku Join &#8216;I Write What I Dream&#8217; Tour</a></li><li> <a href="/audio-release-ugandas-vinka-and-romanias-inna-release-global-smash-single-bebe/">Audio Release: Uganda&#8217;s Vinka and Romania&#8217;s Inna Release Global Smash Single, &#8216;Bebe&#8217;</a></li><li> <a href="/hotkid-ep-honorable-all-about-the-new-kid-on-the-block/">Hotkid EP &#8211; Honorable: All About the new kid on the Block</a></li><li> <a href="/breaking-appeal-court-senator-adeyeye-replaces-him-with-pdps-olujimi/">Breaking: Appeal Court sacks Senator Adeyeye, replaces him with PDP’s Olujimi</a></li><li> <a href="/wenger-set-for-bayern-munich-job/">Wenger set for Bayern Munich Job</a></li><li> <a href="/buhari-fires-35-aides-in-osinbajos-office/">Buhari fires 35 aides in Osinbajo’s office</a></li><li> <a href="/nigerians-drag-british-media-personality-katie-hopkins-over-racist-tweet/">Nigerians Drag British Media Personality Katie Hopkins Over Racist Tweet</a></li><li> <a href="/bbnaija-finalist-cee-c-celebrates-27th-birthday-with-stunning-bikini-photos/">#BBNaija Finalist Cee-C Celebrates 27th Birthday With Stunning Bikini Photos</a></li></ul></div></div><div class="top-info-right right"><div class="social-widgets"><div class="widget pt_magazine_widget_social"><div class="social-widgets"></div></div></div></div></div></div></div><div class="bottom-header"><div class="container"><div class="site-branding"> <a href="/" class="custom-logo-link" rel="home"><img width="400" height="70" src="/wp-content/uploads/2018/01/NEW-Olisa.tv-logo-1-e1516637403880.png" class="custom-logo" alt="olisa"></a></div><div class="header-advertisement"> <a href="//www.firstbanknigeria.com/getfirstmobile/"><img width="594" height="49" src="/wp-content/uploads/2018/07/Firstmobile-web-banner-3.jpg" class="image wp-image-18668 attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="/wp-content/uploads/2018/07/Firstmobile-web-banner-3.jpg 594w,/wp-content/uploads/2018/07/Firstmobile-web-banner-3-300x25.jpg 300w" sizes="(max-width: 594px) 100vw, 594px"></a></div></div></div><div class="main-navigation-holder home-icon-enabled"><div class="container"><div id="main-nav" class="full-width-nav clear-fix"><nav id="site-navigation" class="main-navigation" role="navigation"><div class="home-icon"> <a href="/"><i class="fa fa-home"></i></a></div><div class="wrap-menu-content"><div class="menu-main-menu-container"><ul id="primary-menu" class="menu"><li id="menu-item-25055" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-25055"><a href="/">Home</a></li><li id="menu-item-6498" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6498"><a href="/celebrity/">Celebrity</a></li><li id="menu-item-16698" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16698"><a href="/music/">Music</a></li><li id="menu-item-6500" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6500"><a href="/news/">News</a></li><li id="menu-item-6499" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6499"><a href="/lifestyle/">LifeStyle</a></li><li id="menu-item-6502" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6502"><a href="/sports/">Sports</a></li><li id="menu-item-8077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8077"><a href="/bbnaija/">BBNaija</a></li><li id="menu-item-16732" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16732"><a href="/politics/">Politics</a></li><li id="menu-item-16733" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16733"><a href="/movies/">Movies</a></li><li id="menu-item-16734" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16734"><a href="/fashion/">Fashion</a></li><li id="menu-item-16735" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16735"><a href="/tech/">Tech</a></li><li id="menu-item-28582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28582"><a href="/contact-us/">Contact Us</a></li></ul></div></div></nav></div></div></div></header><div id="content" class="site-content"><div class="container"><div class="inner-wrapper"><div id="primary" class="content-area"><main id="main" class="site-main" role="main"><article id="post-61588" class="post-61588 post type-post status-publish format-standard has-post-thumbnail hentry category-celebrity tag-pete-edochie"><div class="article-wrap-inner"><div class="featured-thumb"> <img width="564" height="495" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.olisa.tv/wp-content/uploads/2019/11/edochie.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" alt="" data-srcset="https://www.olisa.tv/wp-content/uploads/2019/11/edochie.jpg 564w, https://www.olisa.tv/wp-content/uploads/2019/11/edochie-300x263.jpg 300w" sizes="(max-width: 564px) 100vw, 564px"><noscript><img width="564" height="495" src="/wp-content/uploads/2019/11/edochie.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" alt="" srcset="https://www.olisa.tv/wp-content/uploads/2019/11/edochie.jpg 564w, https://www.olisa.tv/wp-content/uploads/2019/11/edochie-300x263.jpg 300w" sizes="(max-width: 564px) 100vw, 564px"></noscript></div><div class="content-wrap"><div class="content-wrap-inner"><header class="entry-header"><h1 class="entry-title">All the Tweets Praising Pete Edochie After a Troll Claimed He&#8217;s a &#8216;Bad Actor&#8217;</h1><div class="entry-meta"> <span class="posted-on"><a href="/all-the-tweets-praising-pete-edochie-after-trolls-claimed-hes-a-bad-actor/" rel="bookmark"><time class="entry-date published" datetime="2019-11-06T12:21:17+01:00">November 6, 2019</time><time class="updated" datetime="2019-11-06T12:23:44+01:00">November 6, 2019</time></a></span><span class="byline"> <span class="author vcard"><a class="url fn n" href="/author/ukamaka/">ukamaka</a></span></span><span class="cat-links"><a href="/celebrity/" rel="category tag">Celebrity</a></span><span class="comments-link"><a href="#respond">No Comment<span class="screen-reader-text"> on All the Tweets Praising Pete Edochie After a Troll Claimed He&#8217;s a &#8216;Bad Actor&#8217;</span></a></span></div></header><div class="entry-content"><p>Nigerians are currently rallying behind Pete Edochie, with many sharing clips of his old exceptional performances, and this all started after a Twitter troll claimed he isn&#8217;t a good actor.</p><p>See the tweet that started all the drama:</p><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Pete Edochie is a really bad actor.</p><p>He&#39;s been playing the same role his entire life.</p><p>Acting isn&#39;t quoting proverbs.</p><p>But Nigerians live and die by seniority so the older he gets, the less anybody is able to point this glaring elephant in the room out.</p><p>&mdash; Oscar Winner Sugabelly 🌕 (@sugabelly) <a href="//twitter.com/sugabelly/status/1191964340016074753?ref_src=twsrc%5Etfw">November 6, 2019</a></p></blockquote><p><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></p><p>And check out the responses with folks on the social app:</p><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Pete Edochie has played Roles of a King, Chief, Herbalist, Ritualist, Villain, Saviour, etc &amp; he has played them well. He gets paid to act his best role tho &amp; I don&#39;t know how that makes him a bad actor but the Person who said it is Sugabelly so it doesn&#39;t Count 🤷‍♂️</p><p>&mdash; King Nonny 👑 (@Zaddy_nomso) <a href="//twitter.com/Zaddy_nomso/status/1192001340064579584?ref_src=twsrc%5Etfw">November 6, 2019</a></p></blockquote><p><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Pete Edochie is truly a bad actor actually. What we want is to see him among the Merry Men, play Sunday Dagboru, get featured in John Wick 4 and act as a grandson to Olu Jacobs in a movie. Is that too much to ask for?</p><p>&mdash; Lola Okunrin (@lollypeezle) <a href="//twitter.com/lollypeezle/status/1192026144909991937?ref_src=twsrc%5Etfw">November 6, 2019</a></p></blockquote><p><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">The fact that Pete Edochie tends to be typecast as the wise old King/Chief in most Nollywood flicks doesn&#39;t necessarily make him a bad actor.</p><p>Samuel L. Jackson is one of Hollywood&#39;s most typecast actors and the man has an Oscar nomination.</p><p>Sugabelly is just being sugabelly.</p><p>&mdash; Adunni Adaora Achebe (@Adunni_Achebe) <a href="//twitter.com/Adunni_Achebe/status/1192033844712615938?ref_src=twsrc%5Etfw">November 6, 2019</a></p></blockquote><p><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Sir Pete Edochie, someone said you are a bad actor. Maybe you should start playing lover boy like IK Ogbonna.<a href="//t.co/yCB0aJ42RB">pic.twitter.com/yCB0aJ42RB</a></p><p>&mdash; Odogwu (@austinaija) <a href="//twitter.com/austinaija/status/1191969482014638080?ref_src=twsrc%5Etfw">November 6, 2019</a></p></blockquote><p><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Since they&#39;ve decided to use Pete Edochie to clout, I guess it&#39;s the appropriate time to drop this clip. <a href="//t.co/MWpFfjzlyS">pic.twitter.com/MWpFfjzlyS</a></p><p>&mdash; DARLINGTON (@Edudarl) <a href="//twitter.com/Edudarl/status/1192006870833217537?ref_src=twsrc%5Etfw">November 6, 2019</a></p></blockquote><p><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">I saw Things fall apart as a kid.</p><p>Pete Edochie cemented his status as a legend with his performance as Okonkwo.</p><p>This Pete Edochie slander wont be tolerated.</p><p>&mdash; Cinderella Man (@Osi_Suave) <a href="//twitter.com/Osi_Suave/status/1192029174397046784?ref_src=twsrc%5Etfw">November 6, 2019</a></p></blockquote><p><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-61588" class="share-twitter sd-button share-icon" href="?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-61588" class="share-facebook sd-button share-icon" href="?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><span class="tags-links"><a href="/tag/pete-edochie/" rel="tag">pete edochie</a></span></div></div></div></div></article><div class="news-col-3 related-posts"><h2 class="related-posts-title">Related Posts</h2><div class="inner-wrapper"><div class="news-item three-column-item"><div class="news-thumb"> <a href="/watch-sarkodies-single-party-n-bullsht-featuring-idris-elba-donaeo/"><img width="400" height="245" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.olisa.tv/wp-content/uploads/2018/07/idris-elba-400x245.jpg" class="attachment-pt-magazine-tall size-pt-magazine-tall wp-post-image lazyload" alt=""><noscript><img width="400" height="245" src="/wp-content/uploads/2018/07/idris-elba-400x245.jpg" class="attachment-pt-magazine-tall size-pt-magazine-tall wp-post-image lazyload" alt=""></noscript></a></div><div class="news-text-wrap"><h3><a href="/watch-sarkodies-single-party-n-bullsht-featuring-idris-elba-donaeo/">Watch Sarkodie&#8217;s Single, &#8220;Party N Bullsh*t,&#8221; Featuring Idris Elba &#038; Donae&#8217;O</a></h3> <span class="posted-date">November 6, 2019</span></div></div><div class="news-item three-column-item"><div class="news-thumb"> <a href="/nigerians-drag-british-media-personality-katie-hopkins-over-racist-tweet/"><img width="400" height="245" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.olisa.tv/wp-content/uploads/2019/11/maxresdefault-400x245.jpg" class="attachment-pt-magazine-tall size-pt-magazine-tall wp-post-image lazyload" alt=""><noscript><img width="400" height="245" src="/wp-content/uploads/2019/11/maxresdefault-400x245.jpg" class="attachment-pt-magazine-tall size-pt-magazine-tall wp-post-image lazyload" alt=""></noscript></a></div><div class="news-text-wrap"><h3><a href="/nigerians-drag-british-media-personality-katie-hopkins-over-racist-tweet/">Nigerians Drag British Media Personality Katie Hopkins Over Racist Tweet</a></h3> <span class="posted-date">November 6, 2019</span></div></div><div class="news-item three-column-item"><div class="news-thumb"> <a href="/jay-z-gifts-meek-mill-and-swizz-beatz-rolex-watches-as-vip-passes/"><img width="400" height="245" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.olisa.tv/wp-content/uploads/2018/06/Dg1gxAzUEAAtFiO-400x245.jpg" class="attachment-pt-magazine-tall size-pt-magazine-tall wp-post-image lazyload" alt=""><noscript><img width="400" height="245" src="/wp-content/uploads/2018/06/Dg1gxAzUEAAtFiO-400x245.jpg" class="attachment-pt-magazine-tall size-pt-magazine-tall wp-post-image lazyload" alt=""></noscript></a></div><div class="news-text-wrap"><h3><a href="/jay-z-gifts-meek-mill-and-swizz-beatz-rolex-watches-as-vip-passes/">JAY-Z Gifts Meek Mill and Swizz Beatz Rolex Watches as VIP Passes</a></h3> <span class="posted-date">November 6, 2019</span></div></div></div></div><div class="author-info-wrap"><div class="author-thumb"> <img alt="" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://secure.gravatar.com/avatar/a32e8a9db484f9c85655ac9c90964fc1?s=100&#038;d=mm&#038;r=g" data-srcset="https://secure.gravatar.com/avatar/a32e8a9db484f9c85655ac9c90964fc1?s=200&#038;d=mm&#038;r=g 2x" class="avatar avatar-100 photo lazyload" height="100" width="100"><noscript><img alt="" src="//secure.gravatar.com/avatar/a32e8a9db484f9c85655ac9c90964fc1?s=100&#038;d=mm&#038;r=g" srcset="https://secure.gravatar.com/avatar/a32e8a9db484f9c85655ac9c90964fc1?s=200&#038;d=mm&#038;r=g 2x" class="avatar avatar-100 photo lazyload" height="100" width="100"></noscript></div><div class="author-content-wrap"><header class="entry-header"><h3 class="author-name">About ukamaka</h3></header><div class="entry-content"><div class="author-desc"></div> <a class="authors-more-posts" href="/author/ukamaka/">View all posts by ukamaka &rarr;</a></div></div></div><nav class="navigation post-navigation" role="navigation"><h2 class="screen-reader-text">Post navigation</h2><div class="nav-links"><div class="nav-previous"><a href="/prayer-not-always-the-solution-ali-baba/" rel="prev">‘Prayer not always the solution’ – Ali Baba</a></div><div class="nav-next"><a href="/bbnaija-finalist-cee-c-celebrates-27th-birthday-with-stunning-bikini-photos/" rel="next">#BBNaija Finalist Cee-C Celebrates 27th Birthday With Stunning Bikini Photos</a></div></div></nav><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="#respond" style="display:none;">Cancel reply</a></small></h3><form action="/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required"></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required"></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200"></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment"> <input type="hidden" name="comment_post_ID" value="61588" id="comment_post_ID"> <input type="hidden" name="comment_parent" id="comment_parent" value="0"></p><p class="antispam-group antispam-group-q" style="clear: both;"> <label>Current <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="7009153002">[email&#160;protected]</a> <span class="required">*</span></label> <input type="hidden" name="antspm-a" class="antispam-control antispam-control-a" value="2019"> <input type="text" name="antspm-q" class="antispam-control antispam-control-q" value="5.5" autocomplete="off"></p><p class="antispam-group antispam-group-e" style="display: none;"> <label>Leave this field empty</label> <input type="text" name="antspm-e-email-url-website" class="antispam-control antispam-control-e" value="" autocomplete="off"></p></form></div></div></main></div><div id="sidebar-primary" class="widget-area sidebar" role="complementary"><aside id="search-4" class="widget widget_search"><form role="search" method="get" class="search-form" action="/"> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s"> <button type="submit" class="search-submit"><span class="screen-reader-text">Search</span><i class="fa fa-search" aria-hidden="true"></i></button></form></aside><aside id="media_image-42" class="widget widget_media_image"><div class="section-title"><h2 class="widget-title">Olisa&#8217;s SUMMER PLAYLIST 2019</h2></div><a href="/olisas-summer-playlist/"><img width="300" height="300" src="/wp-content/uploads/2019/07/Olisas-summer1-300x300.jpg" class="image wp-image-52320 attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="/wp-content/uploads/2019/07/Olisas-summer1-300x300.jpg 300w,/wp-content/uploads/2019/07/Olisas-summer1-150x150.jpg 150w,/wp-content/uploads/2019/07/Olisas-summer1-768x765.jpg 768w,/wp-content/uploads/2019/07/Olisas-summer1.jpg 1010w" sizes="(max-width: 300px) 100vw, 300px"></a></aside><aside id="media_image-44" class="widget widget_media_image"><a href="http://lookartmenow.com/"><img width="300" height="154" src="/wp-content/uploads/2019/01/look-300x154.jpg" class="image wp-image-34578 attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="/wp-content/uploads/2019/01/look-300x154.jpg 300w,/wp-content/uploads/2019/01/look-768x395.jpg 768w,/wp-content/uploads/2019/01/look-1024x527.jpg 1024w,/wp-content/uploads/2019/01/look-320x165.jpg 320w,/wp-content/uploads/2019/01/look-640x329.jpg 640w,/wp-content/uploads/2019/01/look-360x185.jpg 360w,/wp-content/uploads/2019/01/look-720x371.jpg 720w,/wp-content/uploads/2019/01/look-800x412.jpg 800w,/wp-content/uploads/2019/01/look.jpg 1051w" sizes="(max-width: 300px) 100vw, 300px"></a></aside><aside id="media_image-34" class="widget widget_media_image"><a href="http://www.malicecosmetics.com"><img width="300" height="251" src="/wp-content/uploads/2018/12/maria-300x251.jpg" class="image wp-image-31728 attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="/wp-content/uploads/2018/12/maria-300x251.jpg 300w,/wp-content/uploads/2018/12/maria-768x641.jpg 768w,/wp-content/uploads/2018/12/maria-320x267.jpg 320w,/wp-content/uploads/2018/12/maria-640x534.jpg 640w,/wp-content/uploads/2018/12/maria-360x301.jpg 360w,/wp-content/uploads/2018/12/maria-720x601.jpg 720w,/wp-content/uploads/2018/12/maria-800x668.jpg 800w,/wp-content/uploads/2018/12/maria.jpg 1000w" sizes="(max-width: 300px) 100vw, 300px"></a></aside><aside id="media_image-94" class="widget widget_media_image"><img width="300" height="300" src="/wp-content/uploads/2019/10/afrima-300x300.jpg" class="image wp-image-60312 attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="/wp-content/uploads/2019/10/afrima-300x300.jpg 300w,/wp-content/uploads/2019/10/afrima-150x150.jpg 150w,/wp-content/uploads/2019/10/afrima-768x768.jpg 768w,/wp-content/uploads/2019/10/afrima-1024x1024.jpg 1024w,/wp-content/uploads/2019/10/afrima.jpg 1080w" sizes="(max-width: 300px) 100vw, 300px"></aside></div></div></div></div><aside id="footer-widgets" class="widget-area" role="complementary"><div class="container"><div class="inner-wrapper"><div class="widget-column footer-active-3"><aside id="text-117" class="widget widget_text"><div class="textwidget"></div></aside></div><div class="widget-column footer-active-3"><aside id="media_image-3" class="widget widget_media_image"><a href="//olisa.tv/"><img width="400" height="70" src="/wp-content/uploads/2018/01/WHITE-Olisa.tv-logo-e1516637496568.png" class="image wp-image-6487 attachment-full size-full" alt="" style="max-width: 100%; height: auto;"></a></aside></div><div class="widget-column footer-active-3"></div></div></div></aside><footer id="colophon" class="site-footer" role="contentinfo"><div class="container"><div class="site-info-holder"><div class="copyright"> Copyright &copy; All rights reserved.</div><div class="site-info"> olisa.tv</div></div></div></footer></div><div style="display:none"><div class="grofile-hash-map-059280b2344cf8679b3b6fb248f3a8d3"></div></div> <a href="#page" class="scrollup" id="btn-scrollup"><i class="fa fa-angle-up"></i></a> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">window.WPCOM_sharing_counts = {"https:\/\/www.olisa.tv\/all-the-tweets-praising-pete-edochie-after-trolls-claimed-hes-a-bad-actor\/":61588};</script> <script>try{"use strict";(function(){function anti_spam_init(){var i,len,elements,answer='',current_year=new Date().getFullYear(),dynamic_control;elements=document.querySelectorAll('.antispam-group');len=elements.length;for(i=0;i<len;i++){elements[i].style.display='none';}
elements=document.querySelectorAll('.antispam-control-a');if((elements)&&(elements.length>0)){answer=elements[0].value;}
elements=document.querySelectorAll('.antispam-control-q');len=elements.length;for(i=0;i<len;i++){elements[i].value=answer;}
elements=document.querySelectorAll('.antispam-control-e');len=elements.length;for(i=0;i<len;i++){elements[i].value='';}
dynamic_control=document.createElement('input');dynamic_control.setAttribute('type','hidden');dynamic_control.setAttribute('name','antspm-d');dynamic_control.setAttribute('class','antispam-control antispam-control-d');dynamic_control.setAttribute('value',current_year);elements=document.querySelectorAll('form');len=elements.length;for(i=0;i<len;i++){if((elements[i].id==='comments')||(elements[i].id==='respond')||(elements[i].id==='commentform')){var class_index=elements[i].className.indexOf('anti-spam-form-processed');if(class_index==-1){elements[i].appendChild(dynamic_control);elements[i].className=elements[i].className+' anti-spam-form-processed';}}}}
if(document.addEventListener){document.addEventListener('DOMContentLoaded',anti_spam_init,false);}
setTimeout(function(){anti_spam_init();},1000);})()}catch(e){console.log(e)}</script> <script type="text/javascript" src="//s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201945"></script> <script src="/s/f.php?9e713e.js"></script> <script type="text/javascript">var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};</script> <script src="/s/f.php?ac9573.js"></script> <script type="text/javascript">var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});</script> <script type="text/javascript" src="//stats.wp.com/e-201945.js" async defer></script> <script type="text/javascript">_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.8',blog:'64491283',post:'61588',tz:'1',srv:'www.olisa.tv'} ]);
	_stq.push([ 'clickTrackerInit', '64491283', '61588' ]);</script> </body></html>